WHCSRL 技术网

Seata1.2.0 使用mysql8版本配置_hello

seata不支持mysql8最主要的原因就是连接驱动是5版本的,所以将mysql8版本的连接驱动替换掉或者两个都保留也可以。

1.去到seata/lib目录下,将8版本的jar包粘贴到目录下

在这里插入图片描述

2.修改seata/conf/file.conf,driver-class-name = "com.mysql.cj.jdbc.Driver"

在这里插入图片描述

3.启动脚本seata/bin/seata-server.sh

要记得先启动nacos,可以看到服务成功注册到nacos

在这里插入图片描述

 详细配置

1、修改seata-server-1.2.0seataconffile.conf文件

  1. #修改内容如下
  2. 1
  3. ## transaction log store, only used in seata-server
  4. store {
  5.   ## store mode: file、db
  6.   mode = "db"        #!!!!!&#x
推荐阅读