WHCSRL 技术网

Yaml代码bug:load() missing 1 required positional argument: ‘Loader‘

[★] 问题描述

通过open方式读取Yaml文件数据后,再通过load函数将数据转化为列表或字典,代码如下:

# 通过open方式读取文件数据
file = open('../data/data.yaml', 'r', encoding="utf-8")

# 再通过load函数将数据转化为列表或字典
data = yaml.load(file)
  • 1
  • 2
  • 3
  • 4
  • 5

运行时报错提示

Traceback (most recent call last):
  File "E:/03_Jane/OneDrive/PyCharm/SeleniunWebDriver/selenium_基础学习/Yaml_基础学习/demo/test.py", line 17, in <module>
    data = yaml.load(file)
TypeError: load() missing 1 required positional argument: 'Loader'
  • 1
  • 2
  • 3
  • 4

[★] 问题分析

该报错原因提示为load函数缺少必填的Loader参数

[★] 解决方法

  • 方法【1】:添加参数 Loader=yaml.FullLoader

    # 通过open方式读取文件数据
    file = open('../data/data_string.yaml', 'r', encoding="utf-8")
    
    # 再通过load函数将数据转化为列表或字典
    data = yaml.load(file, Loader=yaml.FullLoader)
    
    • 1
    • 2
    • 3
    • 4
    • 5
  • 方法【2】:使用safe_load()函数代替 load()

    由于该load()函数是必需要传入参数 loader=Loader。而我们又没有该Loader参数,所以我们换成 safe_load() 函数则可以不用传Loader参数

  • 方法【3】:降级pyyaml 版本

    当前pyyaml 版本 6.0 与当前 Google Colab 导入包的方式不兼容。因此,只需将 pyyaml 版本降级到与当前 Google Colab 导入方式兼容的 5.4.1。使用这个命令降级 pyyaml !pip install pyyaml==5.4.1

    # 通过open方式读取文件数据
    file = open('../data/data.yaml', 'r', encoding="utf-8")
    
    # 再通过load函数将数据转化为列表或字典
    data = yaml.safe_load(file)
    
    • 1
    • 2
    • 3
    • 4
    • 5
推荐阅读